
IPMaster-Help Documentation

1 System Summarize

IPMaster is IP address management software. It provides visual IP address assignment 

(network  topology  tree),  automatic  subnet  calculation,  mask  calculation,  subnetting, 

network segment scanning, host monitoring, ping, traceroute, telnet, and netsend etc. It 

supports  VLSM (Variable  Length  Subnet  Masks)  and  CIDR  (Classless  Inter-Domain 

Routing).  With the help of IPMaster,  network administrator can increase their  working 

efficiency and avoid fault.  The purpose of  this  software is  to  assign and manage IP 

address efficiently for enterprise network.

2 Running environment

 Operation system: WinNT, WinMe, Win2000, WinXP, Win2003, WinVista, Win 7; 

 Min CPU: 450MHz;

 Min Ram: 64M;

 Min HD Space: 100M;

 Best screen resolution: 1024*768 or above;

3 Glossary

 IP address management library: 

The library to store all IP assigning information.

 Network segment: 

Represents IP range and is the root of IP address management library. It is identified 

by IP address and mask, e.g. 192.168.100.0/24. We can perform subnet dividing 

under it.

 Subnet: 

http://www.microsoft.com/windows/windowsmedia/9series/server/helpdocs.aspx


A smaller network created by dividing a larger network into equal parts, which is 

identified  by  IP  address  and  mask.  There  are  four  types  of  subnet:  assigned, 

subdivisible, reserved, and unused.

 Topological tree: 

The tree shows the affiliation of network segment and subnet. The root of the tree is 

network segment and the subnet is middle node or leaf node.

 Assigned subnet:

This kind of  subnet  can not  be subdivided,  for  this  kind of  subnet,  the user can 

maintain  the  host  information  in  this  subnet.  It  was  showed  as  a  leaf  node  in 

topological tree.

 Subdivisible subnet: 

This  kind of  subnet  can be  subdivided into  smaller  subnet  and was showed as 

middle node or leaf node in topological tree.

 Reserved subnet: 

This kind of subnet was reserved by the user and can not be used.

 Unused subnet: 

This kind of subnet hasn’t been planed and is the remaining network segment other 

than the above mentioned subnet.

 Host: 

It represents a computer or other device on a TCP/IP network. It is a logical mapping 

of each IP address in the assigned subnet. There are 3 types of host: assigned, 

reserved, unused.

4 System Function

4.1 Visual IP address management function

The whole GUI is divided into three parts: the left part is network topology tree to display 

subnet hierarchy, right above part is the property of subnet, right below part is the content 

of subnet (which displays all next level subnets for subdivisible subnet or all hosts in the 



subnet for assigned subnet), the bottom part is tip message area.

Different types of subnet is showed by different colored icon:

 Assigned subnet       

 Subdivisible subnet    

 Reserved subnet      

 Unused subnet         

4.2 New network segment

Clicking ”File->New Network Segment” menu item (or press Ctrl + N), the dialog box of 

”New Network Segment” would appeared, after inputting ”Segment Name” and “Segment 

Address”,  the system will  automatically determine the network mask according to the 

address type and display the information such as  segment  type,  subnet  ID,  address 



range etc. The user can also get the network segment by modifying the mask. There are 

two ways of modifying the mask, one is to input mask address directly, and the other is to 

adjust the mask bits slider. The GUI is displayed as following:

After  clicking  “OK”  button,  the  system  will  establish  a  new  network  segment  under 

“IPMaster-Root” node of topological tree.

The newly established network segment will be placed under ”IPMaster-Root” node and 

become  the  root  of  IP  address  management  library,  in  which  the  node  type  is 

“subdivisible” acquiescently. If further division of subnet is needed, you can right-click the 

node of  the network segment and choose ”Divide Subnet”  menu item on the pop-up 

menu , then you can perform network segment division.



4.3 Automatic subnetting function

Right-click at  the subdivisible node and choose ”Divide Subnet”  menu item, then the 

following dialog box will be appeared to perform subnetting:

After  choosing  ”Automatically  Divide”,  click  “Next”  button,  then  input  ”Amount  of 

Subnets”, ”Hosts in each Subnet” or “Subnet Mask”, as following:

Click ”Next” button, system will generate subnet automatically and will skip the assigned 

and reserved subnet, as following:



The default subnet type generated by the system is “assigned”, the user can modify the 

type of the subnet in this GUI and input the subnet name or cancel the division of some 

subnet  (by uncheck the check box before the subnet),  after  clicking”  OK’ button,  the 

system will generate subnet at the designated node automatically.

4.4 Manual subnetting function

Right-click at the subdivisible node and choose ”Divide Subnet” menu item, then choose 

“Manually Divide” at the popped up dialog box,  click ”Next” button,  the dialog box of 

“Manually Divide”  would be popped up to  perform subnetting,  then input  the ”subnet 

name”, ”IP address”, “subnet mask” and “subnet type” as following:



After click” OK” button, the system will generate a designated subnet by the user.

4.5 Redo and undo function

Clicking ”Edit->Undo Subnet Operation”  menu item or ”Edit->Redo Subnet  Operation” 

menu item can cancel or repeat the last step of subnetting operation.

4.6 Modifying the subnet type directly for the leaf node

As regards the leaf node, the subnet type can directly be modified by choose other type 

at the combo box of ”Node Type”.

4.7 Delete function

Right-click at the node to be deleted, choose ”delete” menu item at the pop-up menu, 

then the appointed subnet would be deleted and all  child subnet represented by sub 

node under this subnet would also be deleted.



4.8 Scan function

Right-click at the node of assigned type, choose ”Scan” menu item at the pop-up menu, 

then the host name, MAC address and user name of all hosts in the assigned subnet can 

be obtained automatically.

4.9 Monitoring function

Clicking ”Tool->Monitor” menu item, the monitor dialog box will pop up. The dialog box 

can monitor the running status of the monitored host. When the host is shutdown, the tip 

message area would warn by red hints and the warning record would be saved into 

“warning.log” file in the directory of the executive program file.

Check ”Monitor”  check box of  the host,  the host would be added into the monitoring 

scope of the system.

4.10 Multi-way of subnet display 

The  system provides  several  display  way  of  subnet  such  as  ”display  assigned  and 

subdivisible  segment”,  ”display  all  segment”,  ”display  assigned  segment”,  ”display 

unused segment”, “display reserved segment”. The default way is ”display assigned and 

subdivisible  segment”.  And  the  system  also  supports  the  display  by  “subnet  ID”  or 

“subnet name”. The default way is “subnet ID”.

It can be selected by click” Display->Subnet Display” menu item.

4.11 Relevant function of host

The system provides functions such as ping, traceroute, telnet, net send etc.  “Net send” 

function can only be available for the windows host, which has already started up the 

Messenger service. Right-click at the host, then you can perform all these operations at 



the pop-up menu, the results of the operation will be displayed in the tip message area.

4.12 User-defined command function

The system provides 4 default functions - ping, traceroute, telnet and net send, the user 

can also customize other function, if the user would like to define the “pathping“ function, 

click  ”Tool->User-defined  Function”  menu  item,  then  input  the  ”Function  Name”  and 

“Function Context” as following:

The “&&host” represents the target host, when running “pathping” function, the system 

will replace “&&host” by the IP address of the target host, for example, right-click at the 

target host ”10.245.72.3”, the “pathpaing” function will be added into the pop-up menu. 

When running pathping function, the system will perform the below command: ”pathping 

–n  10.245.72.3”. 



4.13 User-defined host column

The system allows the user to define the host information column, if the user would like to 

add a “Location” column, click ”Tool->User-defined Column” menu item, then input the 

”Column Name” as following:

Then the user-defined “location” column will be appeared in the host information area.



4.14 Exact find function

Click ”Edit->Exact Find” menu item (or press Ctrl + E), the “Exact Find” dialog box will be 

appeared. The user can search relevant message in the IP address management library 

by subnet ID, host IP or name, it is case sensitive when searching by the name. When 

the object is found, the main screen focus will skip to the object row automatically. If multi 

match result is found, the “Confirm” dialog box will be appeared, double click the object 

row  in  the  “Confirm”  dialog,  the  main  screen  focus  will  skip  to  the  object  row 

automatically.

4.15 Fuzzy find function

Click ”Edit->Fuzzy Find” menu item (or press Ctrl + F), the “Fuzzy Find” dialog box will be 

appeared, the user can search for all match results according to the input content, the 

search  function  isn’t  case  sensitive.  The  user  can  specify  the  search  scope  will  be 

covered in the host columns and subnet columns. In the “Search Result”  dialog box, 

double  click  the  object  row,  the  main  screen  focus  will  skip  to  the  object  row 

automatically.  During the search  process,  the user  can pause or  resume the  search 

operation.

4.16 Saving function

Click ”File->save” menu item (or  press Ctrl  + S),  the IP address management library 

information will  be saved and it will  be loaded automatically when the system running 



next  time.  The data is  saved in the IPMaster.adl  file,  which is in the directory of  the 

executive program file and at the same time the old file will be backed up automatically 

as IPMaster.adl.bk.

4.17 Opening function

Click  ”File->Open  Address  Library”  menu  item  (or  press  Ctrl  +  O),  the  IP  address 

management library information file as .adl format can be opened and displayed.

4.18 Export function

Click ”File->Export”  menu item, all  the information of  the leaf node in the IP address 

management  library  will  be output  to  a  MS Excel  file,  which includes:  subnet  name, 

network segment type, subnet ID, subnet mask, address range and address amount, the 

host information of the assigned subnet will be output at the same time. 

4.19 Import function

The system allows  the  user  to  import  host  information  from a  Excel  file,  click  ”File-

>Import” menu item, then select the import file, the host information in the file will  be 

imported to the system. The first row of the Excel file must be title row, the first column 

name in the title row must be ‘IP Address’, the other column name must be same as the 

IPMaster host information column name, and the sheet name in the Excel file must be 

subnet  ID  (The  corresponding  subnet  must  be  assigned  type),  since  the  MS  Excel 

application don’t  allow using ‘/’ character,  so the ‘/’ character  must  be replace by ‘_’ 

character, this means for the sheet name, subnet ID ‘192.168.0.0/24’ must be replace by 

‘192.168.0.0_24’.

For  example  there  are  a  network  segment  ‘192.168.0.0/23’  and  its  2  subnets 

‘192.168.0.0/24’, ‘192.168.1.0/24’ as below:



We have prepared a Excel file as below:



After import the file, the information in the sheet ‘192.168.0.0_24’ will be imported into the 

subnet  ‘192.168.0.0/24’,  and  the  information  in  the  sheet  ‘192.168.1.0_24’  will  be 

imported into the subnet ‘192.168.1.0/24’.



4.20 Password log in function

The password is not required when you login for the first time.

4.21 Password modifying function

Clicking ”Edit->Modify Password” menu item, the “Modify Password” dialog box will pop 

up and the login password can be modified in this dialog box.

4.22 Multi-users using IPMaster

If you purchased several licenses, multi-users are allowed to use IPMaster at different 

computer, they can share and access the  address library data file on a server. In the 

ordinary case, the address library data is saved in the IPMaster.adl file, which is in the 



directory of the executive program file, but you can put it on a file server to share and 

access it,  and you can also control  the access levels of multi-users by using the file 

permission management of the operation system.

4.23 Examples 

Assumed that three 24-bits mask subnets are to be divided in the network segment of 

“192.168.0.0/22”, and two 26-bits mask child subnets are to be divided under one of the 

subnets, which can be achieved as following.

At first newly establishing a network segment “192.168.0.0/22”, the GUI is as following:

Then dividing three 24-bits mask subnets under the network segment node, the GUI is as 

following:



Clicking ”Next” button, then change the subnet to be continued dividing as “Subdivisible” 

type in the “ Confirm” dialog box.

After  clicking  “OK”,  the  system  will  divide  three  subnets  as  ”192.168.0.0/24”, 

“192.168.1.0/24” and “192.168.2.0/24” under ”192.168.0.0/22” network segment, in which 

the “192.168.1.0/24” subnet is appointed to be “Subdivisible” type.

Continuing  to  divide  two  26-bits  mask  child  subnets  under  the  subdivisible  type 

“192.168.1.0/24” subnet, the GUI is as following:



Clicking ”Next” button,

After  clicking  “OK”,  the  system  will  divide  two  26-bits  mask  child  subnets  as 

“192.168.1.0/26” and “192.168.1.64/26” under “192.168.1.0/24” subnet.



This subnetting example is performed with “Automatically Divide” function. The user can 

also achieve it by “Manually Divide” function.

5 License Agreement

 NO WARRANTY

IPMaster IS SOLD "AS IS" AND WITHOUT ANY WARRANTY AS TO MERCHANT 

ABILITY  OR  FITNESS  FOR  A  PARTICULAR  PURPOSE  OR  ANY  OTHER 

WARRANTIES EITHER EXPRESSED OR IMPLIED. THE AUTHOR WILL NOT BE 

LIABLE FOR DATA LOSS, DAMAGES, LOSS OF PROFITS OR ANY OTHER KIND 

OF LOSS WHILE USING OR MISUSING THIS SOFTWARE. 

 Evaluation and Registration

IPMaster is not free software. You may use this software for evaluation purposes 



without charge for a period of 30 days. If you use this software after the 30 days 

evaluation period, you must pay registration fee.

 Distribution of the evaluation version

You may copy the evaluation version of this software and documentation as you 

wish,  and  give  exact  copies  of  the  original  evaluation  version  to  anyone,  and 

distribute the evaluation version of the software and documentation in its unmodified 

form via electronic means. But you should not charge or requesting donations for 

any  such  copies  however  made  and  from  distributing  the  software  and/or 

documentation with other products without the author's written permission. 

 Registered version

One registered copy of IPMaster can only be used on one computer. If you only want 

to  run IPMaster  on  one computer,  you  only  need to  purchase one license(  one 

license grants you rights to install and use the program on a single PC and can be 

utilized by multiple people, one license can manage unlimited IPs), otherwise you 

need to purchase more than one license. If you purchase more than one license, you 

can obtain preferential price.

Home page: http://www.softsession.com

Consult mailbox: support@softsession.com

6 History of the edition

V1.5:

 Added the function of file import.

 Added the function of fuzzy search.

V1.4:

 Speeded up the data loading when starting the system.

 Cancelled the limitation of the mask bit be over 23 for the assigned subnet.

 Added the function of user-defined command.

 Added the function of user-defined host information column.

 Added exporting the host information in the export function.

mailto:support@softsession.com
http://www.softsession.com/


 Optimized the GUI.

V1.3:

 Fixed several bugs in subnetting function.

V1.2:

 Fixed the bug in V 1.1.

 Optimized the saving function.

V1.1:

 Fixed the bug in V 1.0.

 Added mask bits slider function.

V1.0:

 New release.
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